I want to download Java 7 will Snow Leopard be enough or shall I jus go for Mountain Lion even it hasn't good reviews? I have 2007 Spftware version.

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    According to the Java website, Java 7 will not run with Snow Leopard (OS 10.6). Java 7 requires at least Lion (OS 10.7.3).

    To download Mountain Lion (OS 10.8), one needs to have Snow Leopard already installed and updated to OS 10.6.8 in order to have access to the App Store.

    (Lion is no longer available through the App Store, but may be available as a Legacy product through Apple Customer Service.)

    Before upgrading to any of these OS systems, make sure your Mac meets the System Requirements.

    For example: Snow Leopard requires Intel-based Mac with at least 1GB of memory,
    Mountain Lion requires at least 2GB of memory and a Mac built since mid-2007 to early-2008 (date depends on the Mac Model).

    ----------------

    If you prefer the reliability of the OS you are currently running, consider using Disk Utility to create a new partition on your hard drive and format it as Mac OS Extended (Journaled). Then install Snow Leopard (during install the installer will search your Mac for other partitions with older OS and ask if you want to import OS Setting, files and apps -- do this if you want a copy of all your stuff moved over to the new partition, otherwise don't do it so you have a "clean install"). After updating Snow Leopard to OS 10.6.8, download and install Mountain Lion. (Note: if you are already using Snow Leopard, then use Disk Utility to "RESTORE" the old partition to the new partition (thereby creating a clone), and then start up from one of the partitions and download and install Mountain Lion to that partition.)

    Now you have two partitions, each with a different OS. Simply change Start Up disk System Preference to use either OS (or press OPTION while starting up). My current Mac has 6 different Start Up "disks" for different testing purposes and to allow me to use my old scanner which is not compatible with the newer Operating Systems.

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions