I still have OS X10.4.11. What should i update to next ?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    First check to see whether you have an Intel-based Mac. (Go to Apple menu and select "About this Mac". Look for the word "Intel" anywhere in the description next to "Processor".)

    If you have an Intel-based Mac and at least 1GB of memory, you can upgrade directly to Snow Leopard. Snow Leopard comes on a DVD. Once you startup in Snow Leopard, then go to Apple Menu and do Software Update to bring Snow Leopard up to OS 10.6.8.

    OS 10.6.8 gives you access to the App Store, from where you can download Mountain Lion (OS 10.8). However, if your Mac is old enough to have had OS 10.4.11, it is doubtful it can run Mountain Lion. Mountain Lion will not run on Macs introduced before mid-2007 to early-2009 (the date depends on the model of Mac). (Note: OS 10.5 was introduced in October 2007, so it is almost certain that your Mac is too old for Mountain Lion.)

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions