i just got a 5th gen ipod. I am currently running 10.5.8. What do I need to do to be able to use it?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    You need at least Snow Leopard, 10.6.8, and the most up to date iTunes.

    Was this useful? Answer 1

    9 of 12 people found this useful

Related Questions