i have the iMac G5 OS X Version 10.4.11 how can i upgrade?

i have the iMac G5 OS X Version 10.4.11
Processor :: 2.1 HGz PowerPc G5

Can i update to the snow leopard? if i can, do i have to buy them in order they came out or can i just go to the newest version?? Or am i stuck with tiger?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Snow Leopard does not support legacy hardware (specifically the PowerPC processor).

    Was this useful? Answer 1

    17 of 41 people found this useful

Related Questions