I have the first quad core mac,non intel- with 10.4.11 on it. Can i upgrade to Leopard?will it keep applications for scanner/printer that on 10.4.1 ?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Snow Leopard (10.6) requires an Intel Mac to run, but you can upgrade to Leopard (10.5) on your PPC Mac. Your applications will remain in place, but not guaranteed to run if you upgraded to 10.5. It's best to check the manufacturer's website for any driver/software updates.

    Was this useful? Answer 1

    2 of 2 people found this useful

Related Questions