I have snow leopard. Do I need Lion to set up icloud?

Back To Product

Follow this Question

1 Answer from the Community

  • iCloud requires Mac OS 10.7.5 to run the basic features. If you want to use the full features of iCloud, you need to run Mac OS X 10.8.

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions