I have Snow Leopard on my new i mac, but I can't install Aperture 1, do I have to purchase Aperture 2

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    You probably will, yes, as even Aperture 2 needed an update to be compatible with Snow Leopard.

    Was this useful? Answer 1

    3 of 4 people found this useful

  • Yes.

    Was this useful? Answer 2

    0 of 0 people found this useful

Related Questions