I have osx leopard 10.5.8 With I life 09 and iworks 09. I would like to update to snow leopard, should I get The bundle or the standard update?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    If you have Mac OS X v10.5 with iLife '09 and iWork '09 installed you don't really need the Mac Box Set. Just upgrade your OS to Mac OS X v10.6, everything should work okay.

    Was this useful? Answer 1

    3 of 4 people found this useful

Related Questions