I have OS X 10.6.6 but need 10.8.8 or higher for software I want to run. How best to upgrade?

Mac used to run Adobe Lightroom 2, but to tie in with installation of new hard drive, I now want to install Lightroom 4. Thanks.

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    Do you mean you need 10.8.8 ? Or did you mean 10.6.8 ?

    There is no 10.8.8. The current version of the Mac OS is 10.8.2.

    If you need 10.6.8, simply to to the Apple Menu and select "Software Update". This will update your Mac from 10.6.6 to 10.6.8.

    Was this useful? Answer 1

    5 of 8 people found this useful

  • You probably meant to say you need 10.6.8 or higher (10.8.2 is the highest available version of 10.8, so nothing can currently require 10.8.8). If so, just go to the Apple menu and select Software Update and your 10.6.6 will be updated to 10.6.8.

    Was this useful? Answer 2

    1 of 4 people found this useful

Related Questions