I have OS X 10.5.8 with a PowerPC processor. Is there anything I can upgrade to such as 10.6 or 10.7?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

5 Answers from the Community

  • Best Answer:

    Unfortunately, no.

    Beginning with OS 10.6, the PowerPC processor is not supported.
    An Intel processor must be used.

    Was this useful? Answer 1

    15 of 17 people found this useful

  • No .. 10.6 and up require an Intel processor.

    Was this useful? Answer 2

    11 of 12 people found this useful

  • No, the version of OS X you have is the most up to date version that will run on a Mac with a PowerPC processor.

    Was this useful? Answer 3

    7 of 7 people found this useful

  • 10.5.8 is the latest OS for Powerbooks and PowerMacs.
    Snow Leopard or later does not work on these models.

    Was this useful? Answer 4

    5 of 7 people found this useful

  • Lynne - as its been said the answer is no - suggestion make a donation of this system to a worthwhile charity and then get a new Mac - you will be satisfied that you donated your hardware and happy with the new computer.

    Was this useful? Answer 5

    3 of 16 people found this useful

Related Questions