i have os x 10.5.8 and just got a nano 7th generation. when I try to sync to my mac itunes states I need iTunes 10.7.How do I do this?

I have gone thru the forum answers and I am confused about the needs ( Snow Leopard, Mountain Lion etc etc). Can someone give me very basic step by steps how to upgrade so I can use my new Nano? thx!

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • As you've discovered, your Nano needs iTunes 10.7 or later, which requires Mac OS X 10.6 Snow Leopard or later.

    Assuming you have an Intel Mac, you should purchase and install Snow Leopard. If you have a Power PC Mac, you won't be able to install Snow Leopard and therefore won't be able to run iTunes 10.7.

    Was this useful? Answer 1

    2 of 6 people found this useful

Related Questions