I have OS 10.6.8. When I try to activate the icloud, I don't see an icloud icon but a mobile me icon in its place.

I have 10.6.8-do I need to upgrade to 10.7?

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    To access iCloud natively on a Mac, you need OS X 10.7 (aka Lion).

    Was this useful? Answer 1

    8 of 10 people found this useful

Related Questions