i have original mac mini. Can it run snow leopard os x 10.6

I have the 1.4GHz PowerPc G4 chip

Back To Product

Follow this Question

1 Answer from the Community

  • No, Snow Leopard requires an Intel CPU and you have a PowerPC CPU.

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions