I have Mac OSX 10.5.8 operating system. A software program I want to purchase requires 10.6 Snow Leopard. Do I have to upgrade to get it?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Yes. Unfortunately :/

    Was this useful? Answer 1

    0 of 5 people found this useful

Related Questions