I have Mac OS X Version 10.5.8. Today I purchased the new iphone 5 and it's telling me that I need iTunes Version 10.7. Do I have to have OS X 10.6?

Back To Product

Follow this Question

22 Answers from the Community

Related Questions