I have Mac OS X Version 10.5.8. Today I purchased the new iphone 5 and it's telling me that I need iTunes Version 10.7. Do I have to have OS X 10.6?

Back To Product

Follow this Question

16 Answers from the Community

  • Best Answer:

    Both iTunes 10.7 and the latest release, iTunes 11.0.1, require OS 10.6.8 (Snow Leopard).

    Was this useful? Answer 1

    295 of 352 people found this useful

  • To install iTunes 10.7 or 11 (and I recommend 11), you need OS X 10.6.8.

    To upgrade to 10.6.8 you need an Intel Mac with at least 1GB of RAM and 5GB of disk space and a DVD drive.

    Was this useful? Answer 2

    216 of 263 people found this useful

  • Yes. iTunes 10.7 requires Mac OS X 10.6 or higher.

    Was this useful? Answer 3

    122 of 154 people found this useful

  • Sadly, you do have to have 10.6.8 or later.


    System Requirements:
    • Mac OS X version 10.6.8 or later
    • Safari 4.0.3 or later
    • 350MB of available disk space
    • iTunes in the Cloud and iTunes Match availability may vary by country.


    You must buy the upgrade disk in their store. You could try to find a Mountain Lion disk instead to save time and money.

    Was this useful? Answer 4

    95 of 115 people found this useful

  • For iTunes, yes you will need Snow Leopard (10.6). However, you can still download pictures from your iPhone 5 even with Leopard (10.5), so it's not all bad news here. Also any purchased music can be transferred to your phone via iCloud and your account even with earlier versions of iTunes.

    But for all the features and flexibility that iTunes can provide for your iPhone 5, you will need to upgrade.

    Was this useful? Answer 5

    87 of 103 people found this useful

  • good

    Apple Responds

    Yes, you need to purchase 10.6.8 Snow Leopard to install on your mac.

    Was this useful? Answer 6

    34 of 43 people found this useful

  • yes, you do

    Was this useful? Answer 7

    40 of 62 people found this useful

  • yes

    Was this useful? Answer 8

    16 of 17 people found this useful

  • Yes I will too have 10.6.8

    Was this useful? Answer 9

    23 of 31 people found this useful

  • yes

    Was this useful? Answer 10

    14 of 15 people found this useful

  • yes

    Was this useful? Answer 11

    14 of 15 people found this useful

  • yes

    Was this useful? Answer 12

    24 of 37 people found this useful

  • Yeas

    Was this useful? Answer 13

    17 of 24 people found this useful

  • Yes

    Was this useful? Answer 14

    18 of 27 people found this useful

  • need to up grade

    Was this useful? Answer 15

    14 of 20 people found this useful

  • yes

    Was this useful? Answer 16

    5 of 6 people found this useful

Related Questions