I have Mac os x 10.4 on a 2006 MacBook, can I buy snow leopard? Will it work on my computer?

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    Assuming your MacBook is Intel-based and has at least 1GB of RAM... yes, snow leopard will work. (I "upgraded" my late-2006 iMac from OS 10.4.11 to Snow Leopard.)

    Was this useful? Answer 1

    8 of 10 people found this useful

Related Questions