I have an iMac with a 2.4 GHz Intel Core duo processor. CAn I install snow leopard?

I updated my iPhone 4S OS and now I cannot back my phone up to my iMac with a 2.4 GHz Intel Core duo processor.

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Yes, your iMac can run Snow Leopard, but make sure you have at least 2GB of RAM installed.

    Was this useful? Answer 1

    0 of 0 people found this useful

  • Yes. Snow Leopard will install on your iMac.

    To backup your iPhone, you probably need the latest version of iTunes (currently 11.1.3). The latest version of iTunes requires OS 10.6.8 or later. After installing Snow Leopard make sure to go to Apple menu and do Software Update to update Snow Leopard to OS 10.6.8.

    Instructions for backing up iPhone using iTunes:
    supportDOTappleDOTcom/kb/HT1766 (replace each "DOT" with ".")
    and
    supportDOTappleDOTcom/kb/HT4946

    Was this useful? Answer 2

    0 of 0 people found this useful

Related Questions