I have a powerbook g4 with OS X 10.5.8 ,how can I upgrade to OS X 10.6?

Back To Product

Follow this Question

3 Answers from the Community

  • Best Answer:

    You can't upgrade a G4 above 10.5.8.

    Was this useful? Answer 1

    13 of 15 people found this useful

  • You can't. Snow Leopard requires an Intel CPU, and you have a PowerPC G4 CPU.

    Was this useful? Answer 2

    10 of 11 people found this useful

  • Unfortunately, no. Snow Leopard must have a Mac with an Intel-processor. The G4 is not an Intel-processor.

    Was this useful? Answer 3

    9 of 9 people found this useful

Related Questions