I have a Macbook Pro with OSX 10.4.11 2 GHZ intel core duo 512 MB 667MHZ Ram and bought Snow Leopard to upgrade. But it won't allow me to upgrade.

Although when I place the disc in, it appears on my screen, however when i click on it, it does nothing (doesn't open install program). I've had success in installing it on my other two iMacs. This is the family pack, so I know there more installations available.

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    Snow Leopard requires a minimum of 1GB of RAM. I suggest upgrading your MBP to at least 2GB.

    Was this useful? Answer 1

    4 of 5 people found this useful

Related Questions