i have a macbook can i install snow leopard

its the macbook not pro macbook am i able to install snow leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Snow Leopard requires the following:
    1) Intel processor on a Mac (Mac needs to have been released by Apple before OS 10.7 (Lion) was released in July 2011).
    2) 1 GB of memory

    If you have enough memory, Snow Leopard will run on a MacBook.

    To confirm processor and memory, simply go to Apple Menu and select "About This Mac".

    Was this useful? Answer 1

    2 of 3 people found this useful

Related Questions