I have a Mac OS X version 10.5.8. I tunes is asking for version 11.1 or later plus I am getting the new 5s iphone. What do I upgrade to??

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    In order to sync with the iPhone 5s, the Mac needs to have iTunes 11.1 and OS 10.6.8 or higher.

    In order to install Snow Leopard (OS 10.6) on your Mac you need to first determine if your Mac is Intel-based since Snow Leopard is NOT compatible with Macs that have a PowerPC processor. To find out if your Mac is Intel-based, go to "About This Mac" under the Apple menu and see if the word "Intel" is in the "processor" description. The Mac also needs to have at least 1GB of memory.

    After you install Snow Leopard go to "About This Mac" to see if your Mac is running OS 10.6.8. If not, select "Software Update" under the Apple menu to update to OS 10.6.8. Once OS 10.6.8 is running, you can then install iTunes 11.1.

    You also must have OS 10.6.8 on your Mac if you wish to upgrade to OS 10.7, OS 10.8 or OS 10.9. Of course, your Mac must also meet the system requirements for any of these newer OS's.

    Was this useful? Answer 1

    1 of 1 people found this useful

  • I had the same problem, I bought a new iPhone 5 and tried to sync it and iTunes told me I need the latest ITunes, which doesnt work on my OS X 10.5.8 so I needed to buy Snow Leopard to upgrade and be able to use the iPhone 5.

    so yes, you ned to get Snow Leopard 10.6

    Was this useful? Answer 2

    1 of 2 people found this useful

Related Questions