I have a Mac OS X version 10.5.8- Processor 2.66ghz Intel Core 2 Duo, 4 Memory gb 800 mhz. Need a 10.6 to update it. Is OK SnowLeopard MacOSX10.6?

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    Snow Leopard (which is same as Mac OS 10.6) will install on this Mac. Snow Leopard simply requires a Mac with Intel processor and 1GB of memory.

    (FYI: Snow Leopard may not install on Macs released in 2011 and later, but your Mac is definitely older if running OS 10.5.8 and has Intel Core 2 Duo processor. Snow Leopard will likely run on newer Macs, but will not install on these Macs.)

    Was this useful? Answer 1

    2 of 2 people found this useful

  • Snow Leopard is Mac OS X 10.6.

    Was this useful? Answer 2

    0 of 0 people found this useful

Related Questions