I have a Mac book OS X 10.5.8. I am going to buy an iPad. Do I need to buy Snow Leopard so the two will sinc ? If so, where do I buy it from please?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Yes you need Snow Leopard to run iTunes 11, which is need to sync to an iPad.

    You can buy the Snow Leopard DVD off Apple at apple.com for your country.

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions