I have a iMac PowerPC G5 (3.1) Single Processor w/ Tiger 10.4.11. Will the Mac Box Set work for me? I'm wanting to buy the new CS4 Design Premium.

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Adobe CS4 Design Premium works with Tiger (10.4.11).

    However, the G5 processor you have is too old to work with the Mac Box Set (Snow Leopard/10.6 requires an Intel Processor).

    So keep your Tiger or upgrade to Leopard (10.5), and you'll be fine running CS4.

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions