I have a Dual 2 GHz Power PC G5 - it has been upgraded to 10.5.8 - can I install snow leopard?

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    Nope, sorry. Snow Leopard is only for Macs with Intel processors and at least 1GB of RAM, 5GB of disk space and a DVD drive.

    One more thing - even today's least expensive Mac will probably outperform that old girl. I just upgraded from a dual 2.5GHz G5 to a Mac Mini. Get lots of RAM.

    Was this useful? Answer 1

    9 of 11 people found this useful

  • No. Snow Leopard requires a Mac with an Intel processor.

    Here are the system requirements from Apple's website for Snow Leopard:
    System Requirements
    Mac computer with an Intel processor
    1GB of memory
    5GB of available disk space
    DVD drive for installation
    Some features require a compatible Internet service provider; fees may apply.
    Some features require Apple's MobileMe service; fees and terms apply.


    -DH

    Was this useful? Answer 2

    4 of 5 people found this useful

Related Questions