I have 10.6.8. What do I need to upgrade to?

Back To Product

Follow this Question

1 Answer from the Community

  • Depends on how old your Mac is.

    Macs older than 2007-2009 (date depends on the model) can not run the current Mountain Lion OS (OS 10.8).

    Lion (OS 10.7) is no longer available through the App Store, but may be available as a Legacy Product.

    Was this useful? Answer 1

    2 of 7 people found this useful

Related Questions