I have 10.5.8, iTunes will not work because I require a Quicktime update. Cant update Quicktime cause the OS is too old. Do I upgrade to Snow Leopard?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    yep

    Was this useful? Answer 1

    2 of 3 people found this useful

Related Questions