I an running 10.5.8 and I have an Iphone 5, will this purchase be sufficient in upgrading my software in order to be compatible with my Iphone 5?

I need to upgrade my itunes to 11.0.3, but my computer Model Identifier: MacBook5,2. which only upgrades to 10.5.8, and I need 10.6 or higher I believe. my question is, respectively, do I need to upgrade my software only or is there a hardware upgrade involved as well? will the $20 snow leopard disk be sufficient?

Back To Product

Follow this Question

1 Answer from the Community

  • you would need 10.6.8 in order to use your phone so it is recommended

    Was this useful? Answer 1

    0 of 1 people found this useful

Related Questions