i am using old macbook os x10.5.6 i need to upgrade this. what software should i buy? please help.

My mac os x version 10.5.8 , when i update it it says is up to date. I want to download a new itunes 11.1.
what should i do???

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Check your system requirements against Snow Leopard (10.6). You need to actually buy a new operating system to run the new iTunes. You can do this online or by calling apple care.

    Was this useful? Answer 1

    3 of 3 people found this useful

Related Questions