I am running OS 10.5.8. I can't watch email videos from NM football Club. Get message "can't load plug-in." Will I have to upgrade to Snow Leopard?

I got a message from Chrome that it would no longer support, (or be supported by) OS 10.5.8. Since then, I get the above message every time. I can still watch YouTube videos through Bigpond.

Back To Product

Follow this Question

No Answers have been submitted

Be the first to answer this question.  Answer now

Related Questions