I am presently using Leopard with Lightroom 2 and two Epson Photo printers which are several years old. Will they work with Snow L?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Yes! Snow leopard can run software of previous versions. You may find that support documentation for lightroom is not available for snow leopard however.

    Snow leopard is capable of running programs even from older systems such as 10.1-10.4 ie Tiger.

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions