Have iMac G5 2GHz 512MB RAM running OS X 10.4.11;just bought new iMac + new time capsule;should I move to 10.5 on iMac G5? why? will I need more RAM?

I have an iMac G5 2GHz w/ 512MB RAM running OS X 10.4.11. I just bought a new iMac and a new 1TB time capsule. I want to make best use of the older G5 iMac on the network. I would like it backed up automatically to the new time capsule. Can/should I upgrade the G5 iMac to OS x 10.5 ? why? will I need more RAM? Please answer using OS version numbers not tiger/leopard/snow leopard jargon.

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    You should need more RAM if you do anything more that word processing. In order to use the Time Capsule, you need to install at least 10.5.1 Mac OS X Leopard.

    Was this useful? Answer 1

    4 of 5 people found this useful

Related Questions