does this work on a emac (Mac OS X 10.4.11)

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Only if the eMac is Intel-based (which I doubt). Snow Leopard needs 1) Intel-based Mac, 2) minimum 1 GB RAM, 3) 5 GB of hard drive space, 4) DVD drive.

    I should mention though, that after I upgraded from 10.4.11 to 10.6.5 on my iMac, the iMac is much less stable (especially if Safari 5 has been running).

    OS 10.4.11 was one of the most stable Mac systems I have ever had since I started using Macs in 1988. I had to upgrade in order to run Adobe CS5.

    Was this useful? Answer 1

    4 of 4 people found this useful

Related Questions