Do i need to purchase snow leopard and then also buy lion?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • You must be running at least version 10.6.6 of Snow Leopard in order to install Lion.

    Was this useful? Answer 1

    8 of 22 people found this useful

Related Questions