Cannot open FireFox as of today. If I download 10.6 will it work again. I uninstalled/downloaded 3 times, plus Norton Virus Scan, still does not work

I have Version 10.4.11.

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Firefox requires 10.5 or newer. If you get 10.6, it will work again. make sure you have a computer newer than 2007 to install Snow Leopard onto.

    Was this useful? Answer 1

    3 of 3 people found this useful

Related Questions