can snow leopard support adobe illustrator CS6? It says it requires 10.6.8.

Back To Product

Follow this Question

3 Answers from the Community

  • Snow Leopard is OS 10.6.x.

    Go to Apple Menu --> About This Mac. Under the large "Mac OS X" type in the info window that appears, there is the "Version" number. If it is 10.6.8 you are all set.

    If it is OS 10.6 (or 10.6.1) to OS 10.6.7, simply go to the Apple Menu and select "Software Update" to update the Mac OS to the latest version of Snow Leopard, which happens to be 10.6.8.

    Was this useful? Answer 1

    3 of 7 people found this useful

  • Yes, 10.6.8 is the most up to date version of Snow Leopard, which is available via Software Update after you install any earlier version of Snow Leopard.

    Was this useful? Answer 2

    1 of 3 people found this useful

  • If 10.6.8 is required by Adobe, Snow Leopard should run it fine. You may check to see if your system could use any RAM upgrades before hand so the computer isn't maxed out when running it.

    Was this useful? Answer 3

    2 of 6 people found this useful

Related Questions