Can leopard run on a Power Mac G4

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

3 Answers from the Community

  • Best Answer:

    I've installed OS 10.5.8 (Leopard) on my PowerPC G4, but the docs say 10.6 (Snow Leopard) only runs on Intel.

    Was this useful? Answer 1

    13 of 15 people found this useful

  • This appears to be incorrect...you can't run Snow Leopard (OS X 10.6) with a PowerPC machine (i.e., G5, G4, etc.) but Leopard (OS X 10.5) appears to work on PowerPC machines:

    Unfortunately, I can't add the link to the actual Apple Support article, so go to Apple Support and search for HT3759 which has the requirements for OS X 10.5 (Leopard).

    Was this useful? Answer 2

    13 of 15 people found this useful

  • No you can not. You need an Intel processor

    Was this useful? Answer 3

    6 of 15 people found this useful

Related Questions