Can install snow leopard if I'm currently running 10.5.8?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Snow Leopard requires an Intel processor (not a PowerPC processor) and a minimum of 1GB of memory.

    If your Mac is currently running OS 10.5.8 and has the Intel and memory, it will be able to run Snow Leopard.

    Was this useful? Answer 1

    3 of 3 people found this useful

Related Questions