Are there any known software compatibility issues with Snow Leopard that would affect a Mac OS 10.5.8 user who upgrades?

Would my existing software — especially Adobe Creative Suite 2 and Microsoft Office 2008 — still work on the Snow Leopard system? I just don't want to realize that my programs are too outdated to work.

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    If the programs worked with Leopard, I would think they would work with Snow Leopard.

    I installed Snow Leopard on my Tiger system. Adobe CS3 continues to work (although it seems to work better once I updated to OS10.6.5... OS10.6.4 was less stable). MS Office 2004 works well.

    I have been using 10.6.3, 10.6.4 and 10.6.5. 10.6.5 is more stable than 10.6.4, but doesn't seem to be as stable as 10.4.11 was.

    When I do a major upgrade of any OS, I keep the old system on a separate partition/hard drive. I can always start up from the old OS if I discover a program that doesn't work correctly with the newer OS.

    Was this useful? Answer 1

    4 of 5 people found this useful

Related Questions