(1) Will the upgrade to Snow Leopard work from Panther? (2) Will Final Cut 4 still work on Snow Leopard? I still need it for certain purposes.

I've been running Panther on my old Powerbook specifically because I still need to use Final Cut Pro 4 for certain projects, but I'm finding it difficult to keep my other software up-to-date with such an old OS. Will I still be able to use FCP4 on Snow Leopard? Can I upgrade to Snow Leopard directly from such an old OS as Panther?

Back To Product

Follow this Question

1 Answer from the Community

  • A Powerbook does not have an Intel processor, so cannot run Snow Leopard

    Was this useful? Answer 1

    1 of 2 people found this useful

Related Questions