Is the current AirPort Express compatible with the Mac OS X Mountain Lion?

AirPort Express

Back To Product

Follow this Question

1 Answer from the Community

  • Of corse. All Apple-branded AirPort products are compatible with the latest version of OS X. Ensure that you have the latest version of AirPort Utility.

    Was this useful? Answer 1

    2 of 4 people found this useful

Related Questions