Will Magic trackpad work with Leopard or if not are drivers in the making?

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    No it does not work with Leopard. You will need Snow Leopard, v. 10.6.4 with latest software update.

    Was this useful? Answer 1

    10 of 16 people found this useful

Related Questions