will it work on a emac?

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    No, it requires mac os 10.6, which is not compatible with eMac.

    Was this useful? Answer 1

    8 of 8 people found this useful

Related Questions