what can i do if im using macbook pro with os10.5.8?

Magic Trackpad

Back To Product

Follow this Question

3 Answers from the Community

  • Answer

    You need to install (1) OS 10.6.4 and (2) a separate trackpad update. We can't post URLs here, so to find the trackpad update, go to Support > Downloads, search for "trackpad," then look for the "Magic Trackpad and Multi-Touch Trackpad Update 1.0" download.

    Was this useful? Answer 1

    1 of 1 people found this useful

  • I've tried it on 10.5.8 just to check if you get basic functionality. It gets stuck on the bluetooth pairing screen where you are asked to enter a passcode but it being a trackpad there is no way to input this code.

    So 10.6.4 is a must for now.

    Was this useful? Answer 2

    1 of 1 people found this useful

  • you have to buy snow leopard

    Was this useful? Answer 3

    2 of 5 people found this useful

Related Questions