Is new tarckpadcompatible with iMac G5 running OS X.5.4?

Back To Product

Follow this Question

5 Answers from the Community

  • Best Answer:

    No. The new Magic Trackpad is only compatible with OSX 10.6.4

    Was this useful? Answer 1

    28 of 32 people found this useful

  • Although the box states that it requires 10.6.4 to work, it WILL work on a G5 running 10.5.8, only all the features will not work correctly. Only the basic tracking, clicking, and click-and-drag will work on 10.5.8. The rest of the features will not work.

    I know the above is true because I bought the Magic Trackpad and connected it to my dual 1.8 G5 tower, and the above has been my experience so far.

    Was this useful? Answer 2

    21 of 22 people found this useful

  • It requires 10.6.4 to run, the G5 will not support 10.6.4 so it will not work.

    Was this useful? Answer 3

    23 of 27 people found this useful

  • No, the Magic Trackpad is only capable of working on Macs running Snow Leopard (10.6). Unfortunately for you, Snow Leopard only runs on Intel-based Macs, so your G5 wouldn't qualify.

    Was this useful? Answer 4

    7 of 8 people found this useful

  • No, it says it requires OX 10.6.4.

    Was this useful? Answer 5

    7 of 8 people found this useful

Related Questions