i have macbook 4.1 early 2008 will trackpad work on it ?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    It requires Snow Leopard 10.6.5 or later.

    Was this useful? Answer 1

    3 of 4 people found this useful

Related Questions