I have an iMac 24 with OS X 10.5.8. I was advised that I could use a Track Pad but it doesn't install. Any ideas?

I understand that I need OS X 10.6 or above? Is that correct? How do I get OS X 10.6 or higher? I have tried your Support Downloads but cannot find the right version.

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    Yes. You need OS X 10.6 or higher.

    Was this useful? Answer 1

    6 of 6 people found this useful

Related Questions