does it work with OS 10.5.8

My MacPro uses OS 10.5.8.
I seem to need 10.6.4 to use the magic trackpad I bought.
How do I update the Mac OS?

Magic Trackpad

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    You will have to buy Snow Leopard or wait until Lion comes out for the trackpad to work. Mac OS X v10.6.4 or later

    Was this useful? Answer 1

    11 of 17 people found this useful

Related Questions