Do the multi-touch features of the Magic Trackpad work on older iMac 24/SD models? I have purchased iMac Dec. 2007, that was Mac OSX 10.5.8 at time?

Sales person sold Magic trackpad to me yesterday, but I am not able to see my iMac have anyway to make this work, please advise?
thanks

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    it will but you will need mac osx 10.6.4 snow leopard or better

    Was this useful? Answer 1

    2 of 3 people found this useful

Related Questions